Jump to content


Photo
- - - - -

Nothing I Try Gets One File Deleted....


  • Please log in to reply
3 replies to this topic

#1 jdanniel

jdanniel

    New WinMatrixian

  • Member
  • 20 posts

Posted 27 June 2015 - 03:09 PM

Hello, everyone, I’m using Windows 8.1.

I have an external USB 3.0 hard drive with a folder on it that has six subfolders.  (You can thank an old Mozilla Thunderbird backup program for that.)

 

Inside the last subfolder is an .eml file with a very long file name.  I’ve tried to delete this file, and just can’t.  No matter what I do, I cannot delete this file.  A JPG of the screen I get when I do this is attached to this post.

 

 

If I right-click on the file, I do not see the typical context menu that would normally have Delete, Rename, etc.  It just has Open, Open With, and Send To.

 

I researched this problem via Google and even Bing, and read several instructions on what to do.  NONE worked.  For example:

 

*  I tried installing Unlocker to unlock the file, so that I could delete it or rename it.  That didn’t work.

*  I even tried a few DOS commands in the Command Prompt screen.  I tried DEL, RMDIR, and even DELTREE.  I did this with the regular command prompt, as well as the Admin command prompt. 
   None worked.

*  I tried editing permissions.  That didn’t work.

*  Lastly, I tried going into Safe Mode (via SHIFT + RESTART), and tried playing with the folder and file there, without success.

 

So, I’m asking for help.  How on earth do I get this file deleted

 

It’s not the end of the world if this folder and file are stuck on my external drive.  It’s more an annoyance than a problem. 

 

Actually, I do have a viable solution to this problem:  Backup everything on my external hard drive onto my OTHER external hard drive (except, of course, for the folder in question).  Then, format the first hard drive, and move back everything I backed up.

 

That will be a long, tedious process, because there’s over a Terabyte of data on it.  It seems ridiculous to me to have to spend hours backing up a TB just to delete or rename one e-mail file.

 

Does anyone have any other ideas that might work?  Thank you so much.  J. Danniel

 

Attached Files



#2 lareeth

lareeth

    Super WinMatrixian

  • Member
  • 1,169 posts

Posted 27 June 2015 - 05:30 PM

Have you tried renaming it? I have had this issue before, renaming the file so its shorter, then deleting it worked for me.



#3 uch_haiden

uch_haiden

    WinMatrixian

  • Member
  • 224 posts

Posted 28 June 2015 - 05:14 PM

I also experienced that one. It was a file with a long cryptic filename. The remedy I did was popping in a live linux then deleted it from there.

#4 yanike

yanike

    I am YM. If you don't know me, you will.

  • Global Moderator
  • 4,631 posts

Posted 29 June 2015 - 03:22 PM

1. Was the file placed on the device with a different OS? Use that OS to delete it.

2. Try the Linux Live CD suggested above.

3. Move files off the USB, format it, and move them back.



Want to comment?

Register or Sign In to go completely ad-free!