Jump to content


Photo
- - - - -

Can't Associate .doc files with Word


  • This topic is locked This topic is locked
12 replies to this topic

#1 hab

hab

    Active WinMatrixian

  • Member
  • 996 posts

Posted 21 November 2009 - 09:41 PM

I have Office 2010 Public beta installed on Windows 7 but it won't associate doc files with anything. I've tried Open with.. then choosing Word but after I open it nothing happens . I've also tried Default Programs but that doesn't work either. Is there any other way to do this?

#2 PurplePeopleEater

PurplePeopleEater

    I'm an Android fanboy sue me

  • Member
  • 4,090 posts

Posted 22 November 2009 - 04:08 AM

open word, click ctrl+o and click on the doc file, maybe it'll automatically make it the default

#3 Afzal

Afzal

    Super WinMatrixian

  • Member
  • 1,668 posts

Posted 22 November 2009 - 04:47 AM

I have Office 2010 Public beta installed on Windows 7 but it won't associate doc files with anything. I've tried Open with.. then choosing Word but after I open it nothing happens . I've also tried Default Programs but that doesn't work either. Is there any other way to do this?


first, report the bug

#4 hab

hab

    Active WinMatrixian

  • Member
  • 996 posts

Posted 22 November 2009 - 05:00 AM

open word, click ctrl+o and click on the doc file, maybe it'll automatically make it the default


I've already done that and yea I should report this bug. But is there anything else I could do... to actually make it proper.

Edited by hab, 22 November 2009 - 05:01 AM.


#5 zool

zool

    Kohzoku Oni

  • Member
  • 1,064 posts

Posted 22 November 2009 - 10:44 AM

1. Open regedit
2. Navigate to the following registry branch:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\
3. Browse through all the sub-key under FileExts.
4. Delete the sub-key named UserChoice from Registry Editor under ".doc"

Edited by zool, 22 November 2009 - 10:44 AM.


#6 hab

hab

    Active WinMatrixian

  • Member
  • 996 posts

Posted 22 November 2009 - 05:12 PM

1. Open regedit
2. Navigate to the following registry branch:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\
3. Browse through all the sub-key under FileExts.
4. Delete the sub-key named UserChoice from Registry Editor under ".doc"


I was looking for something like this - will try this out soon

EDIT:

Alright so this is what I find - I should also mention I accidentally made Wordpad the default program for .doc files if that helps at all. Here are the screnshots of the path:


Also, when I use open with - I selected the shortcut to Word (and is called Microsoft Office 2010 component) and it doesn't work:
Posted Image

EDIT2: Alright I deleted the subfolder named UsreChoice and nothing happened (I've restarted my computer). I've tried open with.. Word but it still doesn't appear on the list but any other .exe like powerpoint or excel would.

Attached Files


Edited by hab, 22 November 2009 - 10:10 PM.


#7 hab

hab

    Active WinMatrixian

  • Member
  • 996 posts

Posted 22 November 2009 - 10:11 PM

Still need help --> zool's solution didn't work

I've also tried winword /r + restart and still nothing

Edited by hab, 22 November 2009 - 10:16 PM.


#8 repulsion

repulsion

    My First Post!

  • Members
  • 1 posts

Posted 07 December 2009 - 05:21 AM

Hey Hab, wondering if you ever figured this out. I just installed Windows 7 (clean install after a botched upgrade) on my computer and I'm having the same problem as you: not being able to associate .doc files to Word using the regular channels. If you figured out, I'd appreciate a response. Thanks.

#9 redredbeanbean

redredbeanbean

    New WinMatrixian

  • Members
  • 7 posts

Posted 20 December 2009 - 03:55 AM

Use CCleaner registry utility fix it, i found it somewhere~ :lol:

#10 coldemone

coldemone

    Sleeping Winmatrixian

  • Member
  • 2,029 posts

Posted 20 December 2009 - 08:02 AM

^ CCleaner can actually harm registry files in Windows Vista+.

I had dis problem before. Reinstallation was what I did.

#11 Guest_Elmer J Fudd_*

Guest_Elmer J Fudd_*
  • Guest

Posted 23 December 2009 - 11:10 PM

Hallo frustrated WORD users,
I've just got round this problem using Office 2003 with WINDOWS 7 by renaming the WINWORD executable in folder OFFICE11 from WINWORD to WINWORD.EXE. I then opened Windows Explorer, went to the Folder where my WORD documents were held (documents were opening up with WORDPAD before) but when I right-clicked on a Document, selected "Open with", then "choose default program", then "browse" and select the WINWORD.EXE file, Microsoft Office Word appeared in the Recommended Programs list. Hope this works for you too as it was starting to give me the boak !!

Cheers

#12 NealTheGuitarist

NealTheGuitarist

    Nothing is sound

  • Member
  • 621 posts

Posted 24 December 2009 - 04:16 PM

Hallo frustrated WORD users,
I've just got round this problem using Office 2003 with WINDOWS 7 by renaming the WINWORD executable in folder OFFICE11 from WINWORD to WINWORD.EXE. I then opened Windows Explorer, went to the Folder where my WORD documents were held (documents were opening up with WORDPAD before) but when I right-clicked on a Document, selected "Open with", then "choose default program", then "browse" and select the WINWORD.EXE file, Microsoft Office Word appeared in the Recommended Programs list. Hope this works for you too as it was starting to give me the boak !!

Cheers


WTH!?

@hab:

It's probably a bug. Report it.

I didn't have any problem opening .doc files.

Edited by NealTheGuitarist, 24 December 2009 - 04:17 PM.


#13 Guest_kristo_*

Guest_kristo_*
  • Guest

Posted 24 June 2010 - 08:24 PM

I found best method:

1. Control Panel -> Default Programs
2. Click 'Associate a file type or protocol with a program'
3. Find '.doc' extension and click 'Change program...' button and search 'Microsoft Office Virtualization Handler*'
4. Click 'OK' and it's done! MS Office can associate file to correct MS Office 2010 program.

* If you don't have 'Microsoft Office Virtualization Handler' on the list, you can find it here: 'C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler' (or 'C:\Program Files\Common Files\microsoft shared\Virtualization Handler' while you don't have 64bit operating system) program named 'CVH.exe'.

Want to comment?

Register or Sign In to go completely ad-free!