Jump to content


Photo
- - - - -

windows 7 slow internet speed???

windows 7

  • Please log in to reply
41 replies to this topic

#21 Guest_Prince_*

Guest_Prince_*
  • Guest

Posted 17 January 2010 - 02:20 PM

Hey there is a simple trick to get much better speed in windows 7 internet connectivity.

Click on start menu and in the search box type in gpedit.msc

Inside the new window that pops up click on Computer configuration and then click on administrative templates.

After that click on Network and inside network click on QoS packet scheduler.

Then click on Limit Reservable bandwidth and inside the new pop up window, enable the option and enter a value of 0.

After that click on apply and then close all the windows and reboot the system.

The internet connectivity will be much faster than before since no amount of bandwidth will be held back for windows updates.

Hope you find it working on your system as it did for mine.

#22 Guest_dvl_*

Guest_dvl_*
  • Guest

Posted 19 January 2010 - 05:26 AM

perfect... the cmd command line works...
note:: this issue only applies to you if the softwares are not getting full throttle and the download meter shows full speeds...

steps to follow::
1)right click on cmd and run as administrator
2)copy the command line:: netsh int tcp set global autotuninglevel=disabled
3)right click in the command prompt window at the cursor and it will give you an option to paste
4)execute the command -- it will return ok

you will see that your software now has a similar download speed which matches your download meter.

thanks ruggb

#23 Guest_the_daddy99_*

Guest_the_daddy99_*
  • Guest

Posted 24 January 2010 - 04:18 PM

just a pointer for anyone who is still having this problem, I tried everything i could find to solve this problem had a nightmare with it, updating files for realtek ethernet card, updating my netgear router, changing registry files, disable all ad-ons and all it was is i had an external hard drive via a usb and when i unplugged it my speed went from 50kbs to 6.9mbs just another thing to make sure of

#24 Guest_win7_*

Guest_win7_*
  • Guest

Posted 26 January 2010 - 09:59 AM

You need to turn off Remote Differential Compression
http://www.windowsre...al-compression/


Hell yea ..
my internet was so slow after install windows 7 ,
i did try that command
i don.t know what a hell the command dose but it work

netsh int tcp set global autotuninglevel=disabled

hell man , it a big different. work like a magic ,
thank to the guy who post it in the first place , thank you

#25 Guest_Curtis_*

Guest_Curtis_*
  • Guest

Posted 12 February 2010 - 08:47 AM

The command prompt worked for me.

netsh int tcp set global autotuninglevel=disabled

I had to get on my laptop with VISTA to look it up but I entered it into my desktop and its back to fast speeds.

:)

#26 Guest_Mushfiq_*

Guest_Mushfiq_*
  • Guest

Posted 16 February 2010 - 08:36 PM

I also had this problem with a slow wireless connection with a Linksys WRT300N router (which broadcasts an N signal or "mixed" signal by default) and a Windows 7 machine. It was only slow on Windows 7 machines. I switched the broadcast signal to "g" from "mixed" in the router's setup menu, and that solved my problem. hope this helps.

#27 Guest_the rabbitt_*

Guest_the rabbitt_*
  • Guest

Posted 08 April 2010 - 09:35 PM

java script:emoticon(':no:',%20'smid_12')
YA GOTTA KNOW THIS WAS POSTED IN A VISTA FORUM IN OCTOBER 2006

Run following command from Admin-level command line prompt solved the problem. I think Microsoft will fix this problem. Is that right?

netsh int tcp set global autotuninglevel=disabled


Do it anyway, it worked for me - went from 80kbps to 5800+kbps on www.speedtest.fdn.com
SOOOO much for M$ fixes.

THEN the next time I tried it it was only 900kbps

this on a computer that was running XP at 6000kbps.

7 is installed on a different drive.

The command Post worked for me also thanks a million had dsl tech here could find nothing wrong but i could not even watch video without pausing, after uprading to win7 64bit, did the cmd prompt fix and speeds are back to normal FAAAAAST thxs sooooooo much

#28 Guest_katrash_*

Guest_katrash_*
  • Guest

Posted 15 May 2010 - 03:21 PM

For those with this problem, I would like to add my experience switching to Windows 7.

Recently I went from XP to Win7 but my net speed was so slow and frustrating. I tried many of the things menttioned above but nothing helped. I even thought of going back to XP (the same computer worked very fine then) besides my other 2 computers which are connected to the same router has no problem with connecting to the internet.

Today, I went to net-card properties and changed the speed from Auto Negotiate to 100 Mbps Full Duplex. Like magic ... I have full speed now - even better than with XP.

Steps: Control Panel --> Network and Sharing Center --> Change Adapter Settings --> right click the conection and select properties --> select Configure button --> goto Advanced tab --> look for Link Speed and Duplex --> change Auto Negotiate to 100 Mbps Full Duplex.

Note: the speed might depend on the routed and network card you use. My configuration is "Linksys WRT54G" router and "Intel® PRO/1000 MT Network Connection" net card.

#29 Guest_lisjak_*

Guest_lisjak_*
  • Guest

Posted 02 August 2010 - 07:57 PM

i'm using win 7 x32 and i'm having big problems with downloading speed! i have tryed many (almost all) things listed in forums (like autotuning=disabled and cmd thing and lot more) but nothing really worked. there was post in one forum that there is a problem with your service so i tried it out. after few hours i found out which service is making problems. it's called "base filtering engine" i disabled it and downloading speed was working perfectly fine. But after i disabled this service my windows firewall turned off and antivirus was disabled (i tryed to re-enable it but obviously didn't work -.-) so i don't recommend this to others, but i still want to know what is the problem, so plz help...

#30 Guest_Diane_*

Guest_Diane_*
  • Guest

Posted 15 November 2010 - 09:26 PM

Hey there is a simple trick to get much better speed in windows 7 internet connectivity.

Click on start menu and in the search box type in gpedit.msc

Inside the new window that pops up click on Computer configuration and then click on administrative templates.

After that click on Network and inside network click on QoS packet scheduler.

Then click on Limit Reservable bandwidth and inside the new pop up window, enable the option and enter a value of 0.

After that click on apply and then close all the windows and reboot the system.

The internet connectivity will be much faster than before since no amount of bandwidth will be held back for windows updates.

Hope you find it working on your system as it did for mine.


this helped my internet go from an avg of 16kb/sec to about 25kb/sec, but still no big difference.

I also tried the other cmd command, updated drivers, and whatever else I have found. I've had this problem for months now and it's driving me crazy. My computer had the fastest internet in the house before installing Win 7. Now it is by far the slowest!
Hopefully I'll find something soon to fix the problem.

#31 Guest_grAe_*

Guest_grAe_*
  • Guest

Posted 04 December 2010 - 06:46 AM

thx ruggb, iv spent days trying to fix my download speed issues, "netsh int tcp set global autotuninglevel=disabled" worked a charm....u the man!

#32 Guest_smike_*

Guest_smike_*
  • Guest

Posted 18 December 2010 - 07:40 PM

is the power settings. you need to change settings in cntrl panel - power options - power plan

#33 Guest_Herrana_*

Guest_Herrana_*
  • Guest

Posted 12 January 2011 - 11:10 PM

I had the same problems with Windows 7... Very slow wireless speed from wireless router. Normal DSL speed on-wire. After much research and attempts my trial-and-error, here's what worked for me.
1- Change wireless router encryption to WEP, rather than WPA. (I understand switching to WPA2 could also help with some compatibility issues...)
2- Uninstall router management software that came with router (My D-Link router came with a program called “Network Magic”. It seemed to be interfering with the Windows-7 wireless software that was already installed on my laptop. Uninstalling it noticeably improved my internet speed)
3- In Control Panel/ Network and Internet/ Network Connection: Change wireless adapter settings for the router... In "Properties", unclick "TCP/IPv6"
4- In Control Panel/ Network and Internet/ Network Connection: Change wireless adapter settings for the router... In "Properties/Configure", disable Ad Hoc QoS Mode.
5- In Control Panel/ Network and Internet/ Network Connection: Change wireless adapter settings for the router... In "Properties/Configure", change Wireless Mode to 802.11g
6- In Control Panel/Power Options: Change advanced power settings... Wireless adapter settings: set to Maximum Performance (ON and OFF battery modes).
Hope this helps someone out there...
Herrana

#34 Michael Seelig

Michael Seelig

    My First Post!

  • Member
  • 1 posts

Posted 02 February 2011 - 04:42 PM

I have the exact same problem on my two new installed w7 computers. But the slow down came AFTER I installed BitDefender AntiVirus Software. So disabling the AV software does let the system run without any problems. I am able to turn on the AV software and stop the Base Filtering Engine, which also results to a normal working system. So the problem of the Base Filtering Engine Service is related to the installed AV Software (at least in my case). I identified also several problems:
- Slow DNS Lookup
- Incredible Slow Browsing (even to an internal Browser based App Server)
- Resets of TCP/IP Connections in Browser (I can see that in the browser based Client app, which always lost the connection), while surfing on normal http sites you will not requognize this error, because http calls do not create persistant connections.

If you have a solution or found any other hint, please let us know!

Michael

#35 Guest_marceloz2000_*

Guest_marceloz2000_*
  • Guest

Posted 03 April 2011 - 05:42 AM

I recently upgraded to the final release of Windows 7 Home Premium. All download speeds were between 1% and 10% of normal. After trying everything listed on this site, and things from several other sites. I was finally able to narrow it down to my HDMI cable coming in contact with the antenna for my wireless card. I don't know if this is just a cable with poor insulation but I made sure they we separated and now have a perfect connection again.

I did not have any issue with Vista so I attributed this to some new wireless management, but it turns out that because I pulled the PC out from under my TV while installing 7 and pushed it back in the cable came in contact with the antenna. Drove me crazy!!!



incredible!!!!!!!!!!!!!! I moved my Revo 3610 again far away the HDMI cable and now everything works fine... GREAT!!!!!!!!!!

#36 Guest_Mongole_*

Guest_Mongole_*
  • Guest

Posted 11 April 2011 - 07:47 AM

I was getting between 1k and 10kb/s. Thanks to -spz and his hint on the HDMI cable. I tried re-arranging the cables behind the PC and it fixed my speed problem. I recently did a rebuild and had all my cables jumbled when I re-assembled. Some of the cables were touching the WiFi stick. All fixed now.

#37 Guest_Salvatore_*

Guest_Salvatore_*
  • Guest

Posted 06 June 2011 - 02:35 AM

Hi, I have had this same issue for a week now.

Tried everything in this forum and more, like 6 forums together, nothing helped at all.

My issue was with the Cisco Packet Tracer, V 5.3 to be more specific.

Hope this helps someone having it installed in their computers.

Salvatore.

#38 Guest_RhysIT_*

Guest_RhysIT_*
  • Guest

Posted 25 June 2011 - 11:29 AM

HEY HEY

Okay, So who uses Virtual Box.

There is one simple answer, Dont use networking. The virtual driver of the Host Network Adapter quite literally 'Steals' your internet, even when its not being used. Virtual box takes half of your connection speed and gives it to its Systems!

I disabled that and Viola, It Went Back to normal.

RhysIT

#39 Guest_Idjan deasroje_*

Guest_Idjan deasroje_*
  • Guest

Posted 03 July 2011 - 05:47 AM

I thought it was the PC, but it ended up being my router, too. I just power cycled it, and after a network restart, im back up to full speed! No DOS commands, silly cheatcodes, etc. try that, future troubleshooters.

#40 OverKlockD

OverKlockD

    WinMatrixian

  • Member
  • 212 posts

Posted 03 July 2011 - 08:48 AM

WTH. Huge long ancient guest ridden thread ftw?

Want to comment?

Register or Sign In to go completely ad-free!



Also tagged with one or more of these keywords: windows 7