Jump to content


Photo
* * * * * 4 votes

Windows XP SP3 Patched UxTheme.dll [6.0.2900.5512]

windows xp

  • Please log in to reply
60 replies to this topic

#21 Silverado87

Silverado87

    My First Post!

  • Members
  • 1 posts

Posted 06 June 2008 - 02:39 AM

um so the sp3 is supposed to make sure we cant have themes? i have the vista skin or am i talkin about something else?

#22 WhistAler

WhistAler

    WhistA

  • Member
  • 1,866 posts

Posted 06 June 2008 - 03:46 AM

Silverado87 your custom skin will revert back to the default XP theme after upgrading to SP3. You have to replace the uxtheme.dll file for using your custom theme again.

#23 Airflow

Airflow

    wolfriA

  • Member
  • 796 posts

Posted 16 June 2008 - 02:36 PM

Where do I place the themes after patching?

#24 Liskiller

Liskiller

    Super WinMatrixian

  • Elites
  • 2,045 posts

Posted 16 June 2008 - 04:40 PM

Where do I place the themes after patching?

C:\Windows\Resources\Themes

#25 brand dub

brand dub

    New WinMatrixian

  • Members
  • 4 posts

Posted 04 August 2008 - 04:46 PM

"quote 'Michealm' heres the patcher i used and it works flawlessly on RTM SP3"
"quote "userlogin" I cannot get to my desktop. I have tried logging in safemode and even restarting to the last saved restore point but neither trouble shoot has worked. I am unable to use my computer now and would really appreciate any help you guys could give."


I used to use Replacer and the uxtheme.dll file and worked fine until SP3, The newest dll wasnt working on my PC either. Id get as far as my desktop and as soon as the taskbar started to show my monitor went blank.

But I was able to restore Uxtheme in safe mode "Directory Service Restore Mode" (but not in 'regular' safe mode, it froze while loading agp440.sys) so for anyone attempting to patch your GUI be prepared to boot into a different OS to repair it.

The multi-patch worked flawlessly so thank you :)

#26 JohnnyBamcake

JohnnyBamcake

    My First Post!

  • Members
  • 1 posts

Posted 05 August 2008 - 08:55 AM

I tried it and i did all the steps right but still not working for me ;(

#27 Darthyoda3

Darthyoda3

    ThƎ Unknown

  • Member
  • 260 posts

Posted 05 August 2008 - 12:27 PM

microsoft = phail

#28 AMIRZ

AMIRZ

    Loyal Member and Friend

  • Member
  • 2,033 posts

Posted 10 September 2008 - 02:38 PM

:P Thx alot Liskiller for this. Great job! but i'm using TuneUp Utilities 2008 (TuneUp Styler as apart of the suite) now. It doesnt patch any system files (like WindowsBlinds but for VS) but will apply 3rd party VS (MSStyle) on your system..also works on Xp SP3 and Vista SP1 as well. I know it's a shareware but i recommend just give it a try...very useful (it' also a great utility for maintaning your systems such as Registry cleaner, Defragementor, Desktop customizer, etc) :) . Anyway, good luck!

Edited by AMIRZ, 10 September 2008 - 02:40 PM.


#29 kerrplunk

kerrplunk

    New WinMatrixian

  • Members
  • 2 posts

Posted 11 September 2008 - 09:47 AM

Noob question - sorry!

I have upgraded to XP Pro SP3 (build 2600.xpsp.08413-2111 : Service Pack 3), and have tried to change my uxtheme.dll a few times (with Replacer, UX Patcher and manually) and it appears to work fine, until I reboot, and then the PC gets stuck/hangs on the XP splash screen. I can get into Safe Mode okay, but it won't load XP normally.

Any ideas?

#30 AMIRZ

AMIRZ

    Loyal Member and Friend

  • Member
  • 2,033 posts

Posted 11 September 2008 - 10:30 AM

Noob question - sorry!

I have upgraded to XP Pro SP3 (build 2600.xpsp.08413-2111 : Service Pack 3), and have tried to change my uxtheme.dll a few times (with Replacer, UX Patcher and manually) and it appears to work fine, until I reboot, and then the PC gets stuck/hangs on the XP splash screen. I can get into Safe Mode okay, but it won't load XP normally.

Any ideas?


I recommend Restore your original file first before next try (to make it back normal):

After patching, usually every patch also creates back-up of patched files. Just try to search/find a uxtheme.dll named file with extension like .backup or BAK, etc on System32 folder. Then rename it back to uxtheme.dll for restoring the original file (with original extension only .dll -> e.g. change the name of "uxtheme.dll.backup" to just "uxtheme.dll" as original). Remember, you may have to show extensions for all file types on Explorer before: Explorer menu bar-> Tools -> Folder Options -> View -> Uncheck "hide extensions for known file types". Finally replace back the patched uxtheme.dll file with the original one that you create above by using Replacer, then reboot. You can try to repatch it again later if everything has been OK. I hope it can help you. Good luck :)

Edited by AMIRZ, 11 September 2008 - 10:40 AM.


#31 kerrplunk

kerrplunk

    New WinMatrixian

  • Members
  • 2 posts

Posted 11 September 2008 - 03:43 PM

Solved my problem - it was really the recent NVidia driver uograde I had done that was stopping the loading of XP. Strangely this seemed tempremental as it had worked fine a few times since I updated it.

Anyway, reran the uxtheme installer, and all is working fine.

Thanks for your help.

#32 brand dub

brand dub

    New WinMatrixian

  • Members
  • 4 posts

Posted 16 September 2008 - 12:29 AM

I have upgraded to XP Pro SP3 (build 2600.xpsp.08413-2111 : Service Pack 3), and have tried to change my uxtheme.dll a few times and it appears to work fine, until I reboot, and then the PC gets stuck/hangs on the XP splash screen. I can get into Safe Mode okay, but it won't load XP normally.

One of the above patches worked fine for me on XP MCE SP3... I uploaded the one that DID work for me for you to try.
Attached File  uxtheme_SP3_and_replacer.ZIP   115.62K   1287 downloads

Edit: Sorry I just saw your last post after I wrote this.. I didnt realize there was more... Anyway Ill keep this here for anyone else that needs it

Edited by brand dub, 16 September 2008 - 12:33 AM.


#33 AMIRZ

AMIRZ

    Loyal Member and Friend

  • Member
  • 2,033 posts

Posted 20 September 2008 - 01:06 PM



I have upgraded to XP Pro SP3 (build 2600.xpsp.08413-2111 : Service Pack 3), and have tried to change my uxtheme.dll a few times and it appears to work fine, until I reboot, and then the PC gets stuck/hangs on the XP splash screen. I can get into Safe Mode okay, but it won't load XP normally.

One of the above patches worked fine for me on XP MCE SP3... I uploaded the one that DID work for me for you to try.
Attached File  uxtheme_SP3_and_replacer.ZIP   115.62K   1287 downloads

Edit: Sorry I just saw your last post after I wrote this.. I didnt realize there was more... Anyway Ill keep this here for anyone else that needs it


:) Thx alot for uploading the updated uxtheme.dll patch for Xp SP3 here bro. Though personally i'm still using Tune Up Styler as apart of Tune Up Utilities as i said before, but otherwise i'm sure it still can be very very useful to apply VS especially for people who dont want/have any 3rd party software installed (as Raphael said), Again, thx! :P

As usual, WinMatrix Rocksss! :devil: :P

#34 theroyaljester

theroyaljester

    My First Post!

  • Members
  • 1 posts

Posted 15 December 2008 - 02:31 PM

I need help!!, i followed your guide and my whole computer system crashed, i cannot run any of my programs as a window will pop up mentioning that " this application cannot run as UxTheme.dll is missing" but i followed every step carefully! please help
i cannot even open "system restore"

#35 brand dub

brand dub

    New WinMatrixian

  • Members
  • 4 posts

Posted 23 December 2008 - 06:59 AM

I need help!!, i followed your guide and my whole computer system crashed, i cannot run any of my programs as a window will pop up mentioning that " this application cannot run as UxTheme.dll is missing" but i followed every step carefully! please help
i cannot even open "system restore"


this is why its always a good idea to have a backup hard drive with windows already installed to log into or a HDD enclosure case so you can at least plug your hard drive into someone elses computer...

1.Try logging into safe mode, then using 'replacer.exe' to revert to the backed up uxtheme.dll.
2.If you cant even get into safemode then use the windows xp installation CD to repair system files.
3.If you cant do that then try plugging your hard drive into another computer replace uxtheme.dll into the windows directories (sys32, i386 and driver folders I believe, not sure though so just use replacer.exe).
4.Install a side by side windows on the hard disc. this creates 2 windows directories and two boot options, which normally isnt a good idea but is helpful to have a back up place to boot into to fix your xp OS. Research side-by-side xp installations yourself..sorry.


The uxtheme I uploadd (above) works fine IF you have windows XP service pack 3 - is that what youre using? the instructions are brainless..
1.open replacer.exe and read instructions> open a folder to system32 and drag uxtheme.dll into replacer window.
2.once prompted, drag the patched uxtheme file into replacer window, replace, close window then reboot.

good luck

#36 rajpatel

rajpatel

    New WinMatrixian

  • Members
  • 2 posts

Posted 07 January 2009 - 01:21 AM

can any 1 help plzz i cant apply any windowblinds skin

#37 RickSOLET

RickSOLET

    Super WinMatrixian

  • Member
  • 1,793 posts

Posted 07 January 2009 - 02:05 AM

@rajpatel you need to install WindowBlinds for applying WindowBlinds skin. This patch is only for the MSStyles (visual styles). Don't be a n00b, search Google!

#38 rajpatel

rajpatel

    New WinMatrixian

  • Members
  • 2 posts

Posted 07 January 2009 - 05:27 AM

i allready have installed windowblinds but when i apply any skin yhe skins apply on window classic skin can u hemlp me plzz thanks

#39 AMIRZ

AMIRZ

    Loyal Member and Friend

  • Member
  • 2,033 posts

Posted 17 January 2009 - 12:32 PM

Here is the original author website - Full credits to my Guru Rafael Rivera:

http://www.withinwin...xtheme-patches/

Download Uxtheme.dll patches (patched files) for Windows Xp, Server 2003, Vista, Server 2008, and even Windows 7, all versions/service packs/betas/rtm etc :)

#40 myrrdex

myrrdex

    New WinMatrixian

  • Members
  • 5 posts

Posted 21 January 2009 - 06:33 AM

I am running SP3 Build 2600.

In the first step posted originally:

"How To Replace Uxtheme.dll
1. First of all delete uxtheme.dll file from C:\Windows\system32\dllcache and C:\Windows\ServicePackFiles\i386"

I cannot find C:\Windows\ServicePackFiles\i386 to delete the uxtheme.dll ... Is this normal? Could it be stored elsewhere?

I have shown all hidden folders and typed in the path in the address bar.

So I have completed the rest of the steps without doing that part and I want to confirm if I need to do anything else. Now when I go to Display->Themes->(I am able to change my theme here to new Themes)

However, only some parts of the theme actually change, and I don't have any new 'Windows and Buttons:' or 'Color Scheme' under the Appearance Tab.

I have settled for just downloading themes and trying to use those by placing in the 'C:\Windows\Resources\Themes' However, nothing I place in there works. Is there a special place to download theme files that work with this patched uxtheme.dll file?

TIA

Want to comment?

Register or Sign In to go completely ad-free!



Also tagged with one or more of these keywords: windows xp