Jump to content


Photo
* * * * * 1 votes

Patched UxTheme Files for Windows Vista SP1


  • Please log in to reply
64 replies to this topic

#41 M.Sudoku

M.Sudoku

    Super Duper WinMatrixian

  • Member
  • 2,191 posts

Posted 03 August 2008 - 04:42 PM

^ you have to take ownership of the files before replacing them.

#42 pure_player52

pure_player52

    New WinMatrixian

  • Member
  • 35 posts

Posted 03 August 2008 - 08:19 PM

ok u got it i added those files but i try to use my visual style (Reaper X) but it puts me into the old 98 skin

Edited by pure_player52, 03 August 2008 - 08:40 PM.


#43 Liskiller

Liskiller

    Super WinMatrixian

  • Elites
  • 2,045 posts

Posted 03 August 2008 - 08:42 PM

Restart you PC and try again. Make sure you have successfully replaced those three system files.

Edited by Liskiller, 03 August 2008 - 08:43 PM.


#44 pure_player52

pure_player52

    New WinMatrixian

  • Member
  • 35 posts

Posted 03 August 2008 - 08:54 PM

i did restart i will try again

just tried it and no it did not work i did exaclty what the tut said i took control changed there name to .old and pasted the new ones but cannot use my theme trying to use Reaper X Theme


i have got it to work

hmm 2 bad cant convert styles from XP to vista

Edited by pure_player52, 03 August 2008 - 10:01 PM.


#45 duckDT

duckDT

    My First Post!

  • Members
  • 1 posts

Posted 09 August 2008 - 08:07 AM

i did restart i will try again

just tried it and no it did not work i did exaclty what the tut said i took control changed there name to .old and pasted the new ones but cannot use my theme trying to use Reaper X Theme


i have got it to work

hmm 2 bad cant convert styles from XP to vista

Hey, I have the same problem as you. I took ownership and Full control of all 3 files, then changed extension to .old and copied the 3 new files in. I rebooted and still cant load any theme. I tried rebooting 3 times and still nothing. What did you do to make it work?
Thanks

#46 petrisor-wtf

petrisor-wtf

    WinMatrixian

  • Member
  • 78 posts

Posted 17 August 2008 - 12:30 PM


i did restart i will try again

just tried it and no it did not work i did exaclty what the tut said i took control changed there name to .old and pasted the new ones but cannot use my theme trying to use Reaper X Theme


i have got it to work

hmm 2 bad cant convert styles from XP to vista

Hey, I have the same problem as you. I took ownership and Full control of all 3 files, then changed extension to .old and copied the 3 new files in. I rebooted and still cant load any theme. I tried rebooting 3 times and still nothing. What did you do to make it work?
Thanks


Same here..using vista ultimate..Any ideas?
Thanks

#47 wonton

wonton

    New WinMatrixian

  • Members
  • 7 posts

Posted 23 August 2008 - 05:15 AM

can someone plz upload these files seperate or not use winrar...plzzzz

my winrar doesnt work

#48 timbertide

timbertide

    Super WinMatrixian

  • Member
  • 1,317 posts

Posted 23 August 2008 - 05:53 AM

@wonton download 7-Zip to extract the files. It's free.

#49 BmwBoston

BmwBoston

    New WinMatrixian

  • Members
  • 3 posts

Posted 26 August 2008 - 06:42 PM

I've replaced everything and windows is still acting as though i didn't. Anytime i open a new .msstyles the normal aero theme appears. do i need ot patch any other files? Using a brand new laptop with vista ultimate sp1

Edited by BmwBoston, 26 August 2008 - 06:43 PM.


#50 RickSOLET

RickSOLET

    Super WinMatrixian

  • Member
  • 1,793 posts

Posted 26 August 2008 - 06:50 PM

@BmwBoston
No, just the three dll files. Did you paste the msstyles in the "C:\WINDOWS\Resources\Themes" folder?

#51 BmwBoston

BmwBoston

    New WinMatrixian

  • Members
  • 3 posts

Posted 26 August 2008 - 06:51 PM

@BmwBoston
No, just the three dll files. Did you paste the msstyles in the "C:\WINDOWS\Resources\Themes" folder?

yeah, i don't know what the deal is. opens up the theme manager but still just aero

as long as the new files are insystem32 it should work right? i don't need to mess with the owenership of the new ones or anything do i? another thought i had was that like xp windows is automatically replacing the files with the original ones from some backups. is that possible?

Edited by BmwBoston, 26 August 2008 - 06:53 PM.


#52 OldBloke

OldBloke

    New WinMatrixian

  • Members
  • 5 posts

Posted 28 August 2008 - 10:16 AM

I had the same experience as the people who said replacing the 3 dlls didn't work for them. Now I've got it working and I have a possible theory about why it didn't work for me the first time...

This is in Vista Home Premium 64bit SP1.

The first time (when it failed) I noticed the 3dlls in system32 (shsvcs.dll themeui.dll uxtheme.dll) were different sizes from the patched files I had downloaded, but I replaced them anyway. The result was that it messed up my theme switching, like some other posters have described.

So I restored a saved image of my system from 5 days ago.
This time the 3 dlls in system32 were the same size as the patched files. I replaced them and it all works (now running the Clearlooks style which is very nice).

So why were my unpatched dlls in system32 a different size from how they were 5 days previously?

Possibly because of a Windows update but I don't think so -- on both occasions it was VistaHP 64 with SP1. I think it could be because 3 days ago I installed the trial version of Windowblinds and SkinStudio. I didn't like it and uninstalled it the next day because I'd rather use Visual Styles instead.

Note for those who don't understand about imaging: The older system which I restored from an image was an exact replica of the system the way it used to be, before I had installed and then uninstalled Windowblinds.

Is it possible that Windowblinds changes those dlls, and also other stuff in the system, and fails to restore everything properly when you uninstall the program? And that patching for styles doesn't work on a system that used to have Windowblinds on it?

The usual instructions for patching uxtheme files, in this thread and in other forums too, seem to work for some people and not for others. There must be some difference between their systems. So I'm asking the people who can't get the patching to work whether you have ever installed Windowblinds (even if you have uninstalled it later)?

#53 BmwBoston

BmwBoston

    New WinMatrixian

  • Members
  • 3 posts

Posted 28 August 2008 - 02:38 PM

never touched windowsblinds. The first time I tried replacing my files I think i used the wrong ones (windows server 2008). But now I have al the original files back and can't figure out what the problem is. One thing i've noticed is that when i look at te file versions, everytime I replace the files with the patched ones the product version changes from 6.0.6001.1800 to 6.0.6000.16386. It literally changes versions as I move it into the system32 folder. Is this normal?

Thanks

#54 OldBloke

OldBloke

    New WinMatrixian

  • Members
  • 5 posts

Posted 28 August 2008 - 03:04 PM

never touched windowsblinds.


So maybe I was wrong to blame it on Windowblinds.

There must have been something which changed the unpatched dlls between the time I made that disk image 5 days ago and the time I first tried using the patched files, because they were different sizes.

I still have backup copies of the two lots of unpatched dlls. They have exactly the same version and file version numbers, although they are quite different sizes. When the unpatched dlls were a different size from the patched ones,switching them was a disaster. When they were the same size, switching them was successful.

#55 wonton

wonton

    New WinMatrixian

  • Members
  • 7 posts

Posted 03 September 2008 - 06:36 PM

somebody plz upload unrar plz...

none of the software works. says it stopped working

winrar
winzip
7-zip

all failed

#56 RickSOLET

RickSOLET

    Super WinMatrixian

  • Member
  • 1,793 posts

Posted 03 September 2008 - 07:24 PM

@wonton the files work perfectly. If you can't unrar them, then download the zipped files from HERE.

#57 wonton

wonton

    New WinMatrixian

  • Members
  • 7 posts

Posted 03 September 2008 - 07:37 PM

o didnt know that was the .zip ver thx

#58 haskins69

haskins69

    New WinMatrixian

  • Member
  • 25 posts

Posted 03 September 2008 - 08:04 PM

can upload jzip ,7 zip and pre cracked winrar extreme later busy now working on daughter's car just waiting on part's ,all scan clean with K.A.V. 8 and work great.. let me know ,Ok?? can also up clean un zip theme files and instuctions + take ownership and remove take ownership reg. files [ work great !!] also have right click move to and copy to files . again let me know!!

Edited by haskins69, 03 September 2008 - 08:09 PM.


#59 hamed danger

hamed danger

    www.skinpacks.com

  • Member
  • 520 posts

Posted 23 September 2008 - 05:49 PM

hi i need Replacer for vista to replace hacked files and i need auto uxtheme multi patcher i use TuneUp Utilities and manual uxtheme patcher but not good.

#60 WhistAler

WhistAler

    WhistA

  • Member
  • 1,866 posts

Posted 24 September 2008 - 12:48 AM

^ You can use VistaGlazz beta.

Want to comment?

Register or Sign In to go completely ad-free!