Jump to content


Photo
- - - - -

WUSB54GS v2.0 on Ubuntu


  • Please log in to reply
186 replies to this topic

#21 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 12:20 AM

There are things called "Dependencies" in Linux, basically those are files needed to install a program. What package does it say it's missing?

Edited by ShamusHand, 18 July 2007 - 12:23 AM.


#22 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 01:34 AM

Um, hold on, let me get a screen shot.

#23 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 02:01 AM

I couldn't get a screen shot, but I got a picture with my camera, because I couldn't get the screen shot to the windows partition.

But here is the link.

#24 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 02:15 AM

As I said - dependencies. The package ndisgtk depends on ndiswrapper-utils-1.9. Just download and install the package, and try again. :)

#25 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 02:49 AM

Now when I run ndiswrapper-utils-1.9 it says it's missing ndiswrapper-common...
Wth? :blink:

#26 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 02:50 AM

ndiswrapper-common

#27 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 02:59 AM

Ok, I've got it all installed, now what do I do?
Lmao, sorry.
I feel like such a linux noob.

#28 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 03:06 AM

Ok, I've got it all installed, now what do I do?
Lmao, sorry.
I feel like such a linux noob.

I had the same problem as you, it took three threads in Ubuntu forums until I figured out how to install packages and how the system works... :P
Now do this:

1. Open the terminal (Applications -> Accessories -> Terminal)
2. Put in you Windows Driver CD
3. Drag any *.inf and *.sys files into the terminal, one by one, pressing enter between each one.
4. Reboot

Post back with any results, I hope I didn't forget anything. :)

Edited by ShamusHand, 18 July 2007 - 03:07 AM.


#29 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 03:16 AM

Every time drag a file from my wireless adapters CD, it just says the file, then "Permission denied"
Ugh... :(

Edited by Skot, 18 July 2007 - 03:16 AM.


#30 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 03:24 AM

Every time drag a file from my wireless adapters CD, it just says the file, then "Permission denied"
Ugh... :(

Oh right, sorry!

Type in "sudo", and then drag the file. :)
Sudo (or gksu in some cases) gives you administrator privileges, it's a security feature in Linux. Use it with care, as it gives applications powers to modify and even overwrite certain system files. I was trying to install a game in Ubuntu (which was made for Debian), and when I used sudo, it overwrote Libc6 (Major system file, almost everything depends on it) and the system just froze up, wouldn't boot afterwards. I learned the hard way after reinstalling.

Edited by ShamusHand, 18 July 2007 - 03:27 AM.


#31 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 03:35 AM


Every time drag a file from my wireless adapters CD, it just says the file, then "Permission denied"
Ugh... :(

Oh right, sorry!

Type in "sudo", and then drag the file. :)
Sudo (or gksu in some cases) gives you administrator privileges, it's a security feature in Linux. Use it with care, as it gives applications powers to modify and even overwrite certain system files. I was trying to install a game in Ubuntu (which was made for Debian), and when I used sudo, it overwrote Libc6 (Major system file, almost everything depends on it) and the system just froze up, wouldn't boot afterwards. I learned the hard way after reinstalling.

Ok, every time I type sudo, or gksu, then drag the file to the terminal, then press enter, it just says "unable to execute (file loacation here): Permission denied" :blink:

#32 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 03:37 AM

One more try, type:

sudo ndiswrapper

Then drag the file into the terminal. :)

#33 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 03:51 AM

One more try, type:

sudo ndiswrapper

Then drag the file into the terminal. :)

Ok, look at this.
After I type "ndiswrapper (option)", it just pops up the same list....

And, I'm not even sure which option to choose.

Edited by Skot, 18 July 2007 - 03:56 AM.


#34 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 04:02 AM


One more try, type:

sudo ndiswrapper

Then drag the file into the terminal. :)

Ok, look at this.
After I type "ndiswrapper (option)", it just pops up the same list....

And, I'm not even sure which option to choose.

I'm so stupid! Sorry, here's the correct line:

sudo ndiswrapper -i

and then when you've installed all *.inf and *.sys files, reboot and type in:

ndiswrapper -l

Post back with results.

P.S.: You don't need Autorun.inf

Edited by ShamusHand, 18 July 2007 - 04:05 AM.


#35 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 04:16 AM

and then when you've installed all *.inf and *.sys files, reboot and type in:

ndiswrapper -l

In that code, is that an L, or an i?

Btw, I did not have any .sys files in there...
Only .inf files.

oh, wait, I did it.
And when I typed "ndiswrapper -l"
It says;
autorun: invalid driver
wusb54gs: invalid driver
wusb54gsv2: invalid driver

Ugh. :(

Edited by Skot, 18 July 2007 - 04:17 AM.


#36 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 04:35 AM


and then when you've installed all *.inf and *.sys files, reboot and type in:

ndiswrapper -l

In that code, is that an L, or an i?

Btw, I did not have any .sys files in there...
Only .inf files.

oh, wait, I did it.
And when I typed "ndiswrapper -l"
It says;
autorun: invalid driver
wusb54gs: invalid driver
wusb54gsv2: invalid driver

Ugh. :(

Told you not to install autorun.inf, and I see your problem. While I find the drivers for you, type this in:

lspci

Post here what you get. :)

#37 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 04:42 AM

Yeah, but I had some how already installed it... sorry. :lol:
But anyways, thanks, lemme try it.

Ha, I can't be bothered to type all that in here.
But here is a shot of it.

Edited by Skot, 18 July 2007 - 04:37 AM.


#38 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 18 July 2007 - 04:42 AM

Driver I found:

1. Download driver here. In Windows, extract the files, and from Ubuntu use the following commands:

2. Type in "sudo ndiswrapper -i" and drag BCMRNDIS.INF into the terminal

3. Copy *.sys files by typing in
cp {USB8023K.sys} /etc/ndiswrapper/bcmrndis/usb8023k.sys; cp {RNDISMPK.SYS} /etc/ndiswrapper/bcmrndis/rndismpk.sys
*Replace {USB8023K.sys} and {RNDISMPK.SYS} with actual file locations by dragging them into terminal.

4. You then need to inform ndiswrapper that this driver, bcmrndis, should be used for usbid of WUSB54GSv2 (13b1:0014), by executing ‘ndiswrapper -d 13b1:0014 bcmrndis’

Post back with results. :)

Edited by ShamusHand, 18 July 2007 - 04:50 AM.


#39 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 04:42 AM

Ha, ok, thanks.

Edited by Skot, 18 July 2007 - 04:43 AM.


#40 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 18 July 2007 - 04:53 AM

Btw, thats an exe file.
I extract the files? :blink:
I'm still waiting for it to download, taking three minutes. :lol:

Want to comment?

Register or Sign In to go completely ad-free!