Jump to content


Photo
- - - - -

[HELP!] Ubuntu partition, and dual-boot problems


  • Please log in to reply
28 replies to this topic

#21 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 15 July 2007 - 12:56 AM

Sorry, to edit boot.ini:

1. Right-click My Computer, and then click Properties.
2. On the Advanced tab, click Settings under Startup and Recovery.
3. Under System Startup, click Edit.

In the very bottom, add this line:

multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Then save and close. Now click start, run, and type 'msconfig'. Click on the 'Boot' tab, and click 'Check All Boot Paths'. If it doesn't come up with an error, you're probably good to go. If it does, try booting into Ubuntu anyways - it won't hurt your system. If it still won't work, post back here and I'll see what I can do.

Hope this helps! :)

Okie dokie.
Blah, well when I clicked "Check all boot paths", this came up;

It appears that the following line in the BOOT.INI filedoes not refer to a valid operation system:
"C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console"/cmdnos"
Would you like to remove it from the BOOT.INI file?
Yes - No


So, do I remove that? Or you said "Try booting into Ubuntu anyways", how do I boot into Ubuntu?

Edited by Skot, 15 July 2007 - 12:58 AM.


#22 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 15 July 2007 - 01:19 AM

Ha, figured I'd give restarting a try aswell after doing that ^
I didn't remove that boot though.
But, it just booted right to XP. :lol:

Edited by Skot, 15 July 2007 - 01:20 AM.


#23 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 15 July 2007 - 01:32 AM

I think I forgot something...

Make sure your Boot.ini looks something like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Thankfully, it seems, Windows didn't detect the Ubuntu boot path as invalid. Try it with the above setup, and see if that helps. Whatever happens, post back here. :)

P.S.: You can remove that entry if you want.

Edited by ShamusHand, 15 July 2007 - 01:32 AM.


#24 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 15 July 2007 - 01:39 AM

I think I forgot something...

Make sure your Boot.ini looks something like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Thankfully, it seems, Windows didn't detect the Ubuntu boot path as invalid. Try it with the above setup, and see if that helps. Whatever happens, post back here. :)

P.S.: You can remove that entry if you want.

Mine looks like this at the moment;

[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptOut
C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons
multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

So, do I just remove that one entry from the my computer >properties >advanced >settings >edit.
Or do I remove it using msconfig?

And tell me anything else I need to change in that setup. :P

#25 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 15 July 2007 - 01:59 AM

Change 'timeout=0" to "timeout=30". That's why it just boots into XP! And
Change 'multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect' to 'multi(0)disk(0)rdisk(0)partition(1)\boot="Ubuntu Linux" /fastdetect'


By the way, yeah, just erase it, either way works. :lol:

Post back here with results!

Edited by ShamusHand, 15 July 2007 - 02:03 AM.


#26 idawn

idawn

    Active WinMatrixian

  • Member
  • 379 posts

Posted 15 July 2007 - 03:15 AM

But shamus wont it be better to use live CD to retrieve the grub rather than breaking himself on Windows...? :whistle:

#27 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 15 July 2007 - 03:27 AM

Lmao, well I messed something up.
Doing a full system recovery, I'm on my moms PC.
But anyways, be back when I'm done, and I'll just start all over with doing the Ubuntu thing. Maybe I won't mess up with the partitioning part or what ever this time.
I'll post back here if I need help.

#28 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 15 July 2007 - 03:37 AM

Lmao, well I messed something up.
Doing a full system recovery, I'm on my moms PC.
But anyways, be back when I'm done, and I'll just start all over with doing the Ubuntu thing. Maybe I won't mess up with the partitioning part or what ever this time.
I'll post back here if I need help.

You didn't need to do a full system restore... wait a minute, is this a DELL with built in recovery?

#29 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 15 July 2007 - 10:32 PM


Lmao, well I messed something up.
Doing a full system recovery, I'm on my moms PC.
But anyways, be back when I'm done, and I'll just start all over with doing the Ubuntu thing. Maybe I won't mess up with the partitioning part or what ever this time.
I'll post back here if I need help.

You didn't need to do a full system restore... wait a minute, is this a DELL with built in recovery?

No, haha.
I have a HP.
But, I did something wrong and when I rebooted, it wouldn't boot up.
It said some file was missing or corrupted.
Some file like this;
<Windows root>system32/hal.dll

or something...
But yeah. I ended up having to do a full recovery.
Now I'm on my moms computer because there is something wrong with my wireless router, so I have to get it replaced by Linksys...
The router won't even turn on. I stayed on the phone with Linksys for like 2 hours. :lol:
But, I won't be on much until I get it.
But I will get on with this computer a little 'til then. :whistle:

Want to comment?

Register or Sign In to go completely ad-free!