Jump to content


Photo
- - - - -

[HELP!] Ubuntu partition, and dual-boot problems


  • Please log in to reply
28 replies to this topic

#1 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 13 July 2007 - 10:56 PM

Ok, I'm having some trouble with my Ubuntu.
I posted this in a previous post on "Ubuntu Live CD Problems". Read about my new problem under the quote.


As I stated before, "Don't install 7.04 fresh". It's nothing but problems after the install or when trying to install it. Get 6.10 and upgrade from there. You will have all the needed drivers and everything will work correctly.

Yeah! You definitely need more RAM.

Ugh, yeah.
I booted in safe graphics mode, and I installed it and what not. Gave it 20GB of space in the partition, and now I CAN'T EVEN BOOT IT. I fell asleep as it was installing, woke up, looked at it, and it had a black screen, that had some stuff about SQUASHFS or something, something like "SQUASHFS Error" or something.

So, I took the disk out, restarted, and it just loaded XP. It did a disk check or something, then loaded up, and said it detected new hardware. And said I needed to restart, so I did. And it still loaded XP, with no GRUB menu anywhere. :angry:
Then I went to My Computer, and my C drive only had a little space left, seeing as I partitioned the drive.
But I didn't see the new partition I created for Ubuntu anywhere... :(

So, I have no clue what to do...
I would just delete the Ubuntu partition, but I can't even find it. :no:

Could ANYONE help?


So, after doing all that lastnight, I woke up today, and I figured since I couldn't find the partition, I would pop the CD back in, and try and find the partition that way. Booted the live CD, and clicked install. Then, got to the part where I partition my drive in the steps. I chose manual to see if I could find the Ubuntu partition there...
Once I chose manual, I saw this.

Device............Type............MountPoint..............Format?......................Size.................Used

/dev/sda..........................................................................................................

/dev/sda1........fat32.........../media/sda1............(Check box here)..........5968 MB.........Unknown

/dev/sda2........ntfs............./media/sda2............(Check box here)..........21505 MB.......16500 MB

/devsda3.........ext3............/media/sda3.............(Check box here)..........51805 MB.......2800 MB

/dev/sda5........swap...........................................(Check box here)..........743 MB...........0 MB

After seeing that I'm pretty sure one of those is the Ubuntu partition. But I have no clue which one...
It had the choice to edit and delete those partitions, but I don't know which is the Ubuntu partition.
So I don't know which to delete.

Some help. :(

Edited by Skot, 13 July 2007 - 11:01 PM.


#2 Villain

Villain

    An Old Geek

  • Global Moderator
  • 6,003 posts

Posted 14 July 2007 - 04:55 AM

SDA1 is Fat32, the old Win98 file system... it might also be a jumpdrive or something
SDA2 is obviously your Windows partition...
SDA3 is EXT3, is a Linux file system, so that will probally be it.
SDA5 is Swap, meaning the linux SWAP file fystem.

So if you want to delete the linus ones, delete just SDA3, because you will need the SWAP for if your going to try ubuntu / linux again. if not, delete SDA3 and SDA5, But before you do so, boot in to windows and go in to safe mode command prompt, and run "fixmbr", because if you dont, you will lose the MBR due to GRUB is on SDA3, and once you Del'ed SDA3 then your gonna loos the option to boot.

So pop in to Windows, run from safe mode command prompt "fixmbr" (dont use the quotes), reboot, with the ubuntu Disk in the cdrom, run GParted from the ubuntu disk, Delete SDA3 and SDA5, then if you want to, try to merge the free space back in to SDA2, then reboot again, this time w/o the ubuntu disk in the drive, and windows should pop up and load again.

hopefully this helps/

please forgive me if i typed anything wrong, i am drunk right now, but this is how you do it. trust me, i have done it a million times before.

#3 Windawg

Windawg

    New WinMatrixian

  • Members
  • 12 posts

Posted 14 July 2007 - 05:04 AM

Why run ext3 when reiserfs is available? :)

#4 idawn

idawn

    Active WinMatrixian

  • Member
  • 379 posts

Posted 14 July 2007 - 05:08 AM

SDA1 is Fat32, the old Win98 file system... it might also be a jumpdrive or something
SDA2 is obviously your Windows partition...
SDA3 is EXT3, is a Linux file system, so that will probally be it.
SDA5 is Swap, meaning the linux SWAP file fystem.

So if you want to delete the linus ones, delete just SDA3, because you will need the SWAP for if your going to try ubuntu / linux again. if not, delete SDA3 and SDA5, But before you do so, boot in to windows and go in to safe mode command prompt, and run "fixmbr", because if you dont, you will lose the MBR due to GRUB is on SDA3, and once you Del'ed SDA3 then your gonna loos the option to boot.

So pop in to Windows, run from safe mode command prompt "fixmbr" (dont use the quotes), reboot, with the ubuntu Disk in the cdrom, run GParted from the ubuntu disk, Delete SDA3 and SDA5, then if you want to, try to merge the free space back in to SDA2, then reboot again, this time w/o the ubuntu disk in the drive, and windows should pop up and load again.

hopefully this helps/

please forgive me if i typed anything wrong, i am drunk right now, but this is how you do it. trust me, i have done it a million times before.


No Matter u drunk...! U r perfect ;)

#5 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 10:54 AM

SDA1 is Fat32, the old Win98 file system... it might also be a jumpdrive or something
SDA2 is obviously your Windows partition...
SDA3 is EXT3, is a Linux file system, so that will probally be it.
SDA5 is Swap, meaning the linux SWAP file fystem.

So if you want to delete the linus ones, delete just SDA3, because you will need the SWAP for if your going to try ubuntu / linux again. if not, delete SDA3 and SDA5, But before you do so, boot in to windows and go in to safe mode command prompt, and run "fixmbr", because if you dont, you will lose the MBR due to GRUB is on SDA3, and once you Del'ed SDA3 then your gonna loos the option to boot.

So pop in to Windows, run from safe mode command prompt "fixmbr" (dont use the quotes), reboot, with the ubuntu Disk in the cdrom, run GParted from the ubuntu disk, Delete SDA3 and SDA5, then if you want to, try to merge the free space back in to SDA2, then reboot again, this time w/o the ubuntu disk in the drive, and windows should pop up and load again.

hopefully this helps/

please forgive me if i typed anything wrong, i am drunk right now, but this is how you do it. trust me, i have done it a million times before.

Lmao, well thanks.
Drunk or not, that all sounds about right to me.
And I thank you for helping me. :)

But, wait.
I do want to try and get Ubuntu to work...
But before I delete just sda3, do I still go into windows and do the command prompt thing? Or do I just go ahead and delete sda3, and reboot and install Ubuntu again?

Edited by Skot, 14 July 2007 - 11:08 AM.


#6 idawn

idawn

    Active WinMatrixian

  • Member
  • 379 posts

Posted 14 July 2007 - 12:06 PM

U can do it two ways...!
-Either goto to command prompt in safe mode n do fixmbr before deleting sda3 as @solo said..!
-Else After deleting sda3 boot with ur windows XP Cd n enter recovery console n do fixmbr to retrieve ur mbr..!

#7 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 12:15 PM

Thanks. I think I'll do the command prompt then delete sda3.
I don't wanna have to mess with my XP recovery CDs and what not.

#8 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 12:32 PM

Rofl, now I feel dumb...
How do I boot up Windows in safe mode?
I've only done that like twice, and it was when I had a major problem with my computer, and it gave me the choice to do it.

#9 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 12:59 PM

Press F8 while BIOS is loading. :)

#10 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 01:05 PM

Edit: Pressing F8 while BIOS is loading, isn't working. It doesn't do anything...
Thanks!!! LOL.

Also, I don't know if you guys read my other post, that I quoted in this post up at the top, but when I installed Ubuntu, I never had to the GRUB menu at start up. My system basically ignored Ubuntu. I didn't see the partition, nor did I get the GRUB menu on boot up.
So, what do you guys think happened, so I won't mess up this time?

Edited by Skot, 14 July 2007 - 01:09 PM.


#11 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 01:35 PM

Firstly, were you still able to boot into Windows normally? And second, you can't see an 'ext3' partition, Windows just ignores it. :)

#12 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 01:52 PM

Firstly, were you still able to boot into Windows normally? And second, you can't see an 'ext3' partition, Windows just ignores it. :)

Well, yes I was able to boot normally, but I don't know how to get into safe mode...
And pressing F8 as the BIOS loads, does nothing.

And, it ignores it?
Then how do I get the GRUB menu, and what not to appear, so I can load Ubuntu?

Edited by Skot, 14 July 2007 - 03:28 PM.


#13 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 04:14 PM

I think you have to create an entry in the Windows boot.ini file... I found guide about that somewhere... :huh:

#14 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 05:17 PM

I think you have to create an entry in the Windows boot.ini file... I found guide about that somewhere... :huh:

Huh? :blink:

Oh lord.
Could you give me the link?

Edited by Skot, 14 July 2007 - 05:18 PM.


#15 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 05:38 PM

Even though I can't find it, this comes pretty close. The guide wasn't written for your exact purpose, but I think it still fits. :)
If anything goes wrong, just pop in your Windows XP installation disc, go in recovery mode, and type in "fixmbr" and "fixboot". Don't worry, it's not a big deal, and you don't risk losing anything. ;)

Edited by ShamusHand, 14 July 2007 - 05:40 PM.


#16 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 05:51 PM

Even though I can't find it, this comes pretty close. The guide wasn't written for your exact purpose, but I think it still fits. :)
If anything goes wrong, just pop in your Windows XP installation disc, go in recovery mode, and type in "fixmbr" and "fixboot". Don't worry, it's not a big deal, and you don't risk losing anything. ;)

Rofl, there really isn't a simple way of doing this, is there?
All I wanted to do is when I got my damn Ubuntu CD was pop it in, reboot, install, and it partition, and create the damn partition for me. And create the damn GRUB menu.
From the things I've read up on, no one has really had this kind of trouble.

#17 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 07:07 PM

Chill out, dude. I think something when wrong with the setup while GRUB was set up. I guess, like I said, add a reference to GRUB in the boot.ini file. Besides that, there isn' much more I can help you with. I'm not sure if this will work, but try adding this line to boot.ini:

multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Then click run, type 'msconfig', and click on the 'boot' tab. Now click 'Check All Boot Paths'. If nothing come up wrong, then you're good to go. If some thing does come up wrong, delete the boot path. Other than that, there's not much more i can do... :)

#18 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 09:43 PM

Chill out, dude. I think something when wrong with the setup while GRUB was set up. I guess, like I said, add a reference to GRUB in the boot.ini file. Besides that, there isn' much more I can help you with. I'm not sure if this will work, but try adding this line to boot.ini:

multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Then click run, type 'msconfig', and click on the 'boot' tab. Now click 'Check All Boot Paths'. If nothing come up wrong, then you're good to go. If some thing does come up wrong, delete the boot path. Other than that, there's not much more i can do... :)

Ha, sorry. I'm chilled.
I've just been fooling with this since I got the Ubuntu disk in the mail...
Which was... um, like 4 days ago, I believe.
Took me two days to get it installed, once installed this stuff happens.
Sorry about flippin' out. :P
Anyways, I'm going to try what you've just said.
If that doesn't work, I'm just gonna do my best to delete the partition, and say screw it. :lol:

Also, you said "I guess, like I said, add a reference to GRUB in the boot.ini file.".
What do you mean? I'm not sure what that means. :lol:
And, could you tell me where to find the boot.ini file?
I'm assuming it's in my "Windows" file?

Edited by Skot, 14 July 2007 - 09:46 PM.


#19 Skot

Skot

    f**k sleep!

  • Member
  • 694 posts

Posted 14 July 2007 - 10:53 PM

Well, I did a search for boot.ini, and all I found was "boot.ini.comodofirewall"
I just got that firewall like 5 days ago. But it says the last time that file was modified was in 2005...

#20 ShamusHand

ShamusHand

    Super WinMatrixian

  • Member
  • 1,574 posts

Posted 14 July 2007 - 11:01 PM

Sorry, to edit boot.ini:

1. Right-click My Computer, and then click Properties.
2. On the Advanced tab, click Settings under Startup and Recovery.
3. Under System Startup, click Edit.

In the very bottom, add this line:

multi(0)disk(0)rdisk(0)partition(2)\boot="Ubuntu Linux" /fastdetect

Then save and close. Now click start, run, and type 'msconfig'. Click on the 'Boot' tab, and click 'Check All Boot Paths'. If it doesn't come up with an error, you're probably good to go. If it does, try booting into Ubuntu anyways - it won't hurt your system. If it still won't work, post back here and I'll see what I can do.

Hope this helps! :)

Edited by ShamusHand, 14 July 2007 - 11:13 PM.


Want to comment?

Register or Sign In to go completely ad-free!